Google Dialer потрапив у відкритий доступ помилково

Сьогодні ми вже писали, що офіційний додаток “Телефон” від Google став доступний в Google Play практично всім користувачам пристроїв на Android 6.0 Marshmallow, а не тільки власникам смартфонів лінійки Nexus. Слідом за цим вийшло ще одне оновлення, після якого власники сторонніх пристроїв більше не можуть завантажити цю програму з магазину. Крім цього, ті, хто встиг встановити програму, не можуть оновитися до більш свіжої версії.

Як виявилося, Google помилково відкрила доступ всім користувачам Android 6.0 і поспішила виправити це з оновленням.

Нова версія програми 2.5.12_rc9 вимагає в пам’яті пристрою спеціальну бібліотеку “/system/framework/com.google.android.dialer.support.jar”, якої немає на пристроях, які не належать до лінійки Nexus. Тому навіть якщо завантажити APK-файл і спробувати встановити його вручну, то поставити додаток не вийде.

Таким чином, скористатися офіційним діалером від Google можуть тільки ті, хто встиг встановити стару версію програми.

Джерело інформації: AndroidPolice